You can translate the question and the replies:

SPENO Authentication REST Webservice

I have been successful in enabling kerbros setup over my denodo server. There are datasource acceptiing keberos authentication are working well. In one of the REST webservice, after enabling the HTTP SPNEGO (kerberos). Even on the chome browser it's prompting for basic credentials which too do'nt work and keep on prompting again and again. Canceling that shows; 401{You are not authorized to access this resource.}. Any idea where i am missing off?
user
10-05-2019 08:48:34 -0400

1 Answer

Hi, I would suggest you to make sure that while using HTTP SPNEGO, the http requests from the browser must contain the Fully Qualified Domain Name: In order to authenticate into VDP server, HTTP/<FQDN> must be the Service Principal Name defined in VDP server. The beginning of the requested URLs must follow the pattern http://www.<FQDN> or http://<FQDN> so the browser requests a Kerberos ticket for HTTP/<FQDN>. Additionally, you can enable Kerberos debug mode to resolve the issue. For enabling Kerberos in Northbound connections, you can follow the steps 1 through 4 in the knowledge base article [Kerberos configuration and troubleshooting](https://community.denodo.com/kb/view/document/Kerberos%20configuration%20and%20troubleshooting?category=Security) under the section, Kerberos debug mode. Also, if you are a customer with a valid support account, you can open a support case at support.denodo.com. Hope this helps!
Denodo Team
13-05-2019 19:14:27 -0400
You must sign in to add an answer. If you do not have an account, you can register here