You can translate the question and the replies:

Npgsql using EF Core

While trying to connect to the Denodo VDP using the sample set provided I am getting the NpgsqlException: Unknown message code 43. Looking at the VDP error log on the server it shows that there is some error with the Kerberos authentication: Error: authentication error: No valid Kerberos authentication for user This is my connection string: @"Server=MyServer;" + "Port=9996;" + "Database=catalog;" + "Username=MyUsername;" + "Password=MyPassword;" + "Integrated Security=true;" + "Kerberos Service Name=HTTP;" + "ssl mode=Disable;" Any ideas what may be causing the issue or what the error code 43 is that Npgsql is getting? We are hitting against the VDP server but we are being rejected due to authentication but everything in the connection string appears to be set up correctly.
user
19-06-2019 17:40:57 -0400

1 Answer

Hi, I would perform the following checks to resolve the 'Error: authentication error: No valid Kerberos authentication for user': * I would make sure to use a minimum of 2.2.7 version of the Npgsql provider. * If the User Name present in Active Directory is used to connect to Virtual DataPort, then sometimes while using ODBC client connections, Active Directory may block Virtual DataPort from utilizing the account provided. * To resolve this, it is needed to adjust the value of userWorkstations attribute in Active Directory in order to enable Virtual DataPort to access this account. You could take a look at the Knowledge Base (KB) Article [Kerberos configuration and troubleshooting](https://community.denodo.com/kb/view/document/Kerberos%20configuration%20and%20troubleshooting?category=Security) and [Using Kerberos Authentication](https://community.denodo.com/docs/html/browse/7.0/vdp/developer/access_through_an_ado.net_data_provider/using_kerberos_authentication/using_kerberos_authentication#using-kerberos-authentication) section under the Virtual DataPort Developer Guide for more details. Hope this helps!
Denodo Team
20-06-2019 08:29:32 -0400
You must sign in to add an answer. If you do not have an account, you can register here