ODBC error "view pg_database not found"

Hello, I've been successful in using both the 32 and 64 bit Denodo ODBC drivers to connect to my VDP 7.0 Express installation using a wide range of clients (PowerBI, Winsql, RStudio, Python, ...) but when I attempt to import the Denodo views in a data modelling suite like Embarcadero ERStudio or Sparx Enterprise architect he does not seem to be able to read the "system tables" (he presents the error "view pg database not found" It would appear that the driver does not disclose these pg-tables that are necessary to reverse engineer the schema. Is there some additional configuration setting I'm missing or does the Denodo ODBC driver not completely implement the Postgres interface? Thanks in advance, Arnest
user
26-07-2019 02:51:24 -0400

1 Answer

Hi, If you want to connect from ERStudio to Denodo to get the Metadata, try to follow the KB article on setting up ODBC for connections to VDP: https://community.denodo.com/kb/view/document/Northbound%20Connections/DSN%20configuration%20for%20ODBC%20connections%20to%20VDP If you want to import an ERStudio model to a Denodo database, you can use the [Denodo Model Bridge tool ](https://community.denodo.com/docs/html/document/denodoconnects/7.0/Denodo%20Model%20Bridge%20-%20User%20Manual)available in the Support Site. In order to overcome “view pg_database not found” error, I would create a new mock view called pg_database in the Virtual DataPort as per the schema described in the [pg_database documentation](https://www.postgresql.org/docs/8.4/catalog-pg-database.html). For example, you could execute the below statement in the VQL shell of the Virtual DataPort Administration Tool. CREATE OR REPLACE VIEW pg_database as SELECT NULL AS datname, NULL AS datdba, NULL AS encoding, NULL AS datcollate ... FROM dual(); Hope this helps!
Denodo Team
26-07-2019 13:27:05 -0400
You must sign in to add an answer. If you do not have an account, you can register here