You can translate the question and the replies:

Query Running for long time

My view query is running for hours but data is not fetching and query is not getting failed as well. Please let me know why is it taking hours of time and not fetching any. I tried multiple times and also deleted and created the view and tried running it but facing the similar issue.
09-09-2019 19:07:26 -0400

1 Answer

Hi, There is a chance that the data is being returned and the query is fetching a big result set. You could check the value of the query timeout in the Virtual DataPort Administration Tool by going to “Tools -> Admin Tool Preferences -> Connection” . This value could have been set to a higher value due to which the query is not timing out. I would recommend to set it back to its default value, which is 900000 milliseconds, so that the querying stops when the timeout is reached. Hope this helps!
Denodo Team
11-09-2019 11:20:43 -0400
You must sign in to add an answer. If you do not have an account, you can register here