You can translate the question and the replies:

Base View date field is populating incorrect format

Hello, We have a base view that is populating a date field incorrectly. The date field should be populated under the format of date time with the time being zeros **(example Tue Jul 29 00:00:00 EDT 1947)** , however for a number of recrods we are seeing **Tue Jul 29 01:00:00 EDT 1947**. For some reason a 1 is being added to the time. Can you please advise as to what could be causing this and what we can do to resolve the problem? Thank you
user
22-10-2019 15:16:24 -0400

3 Answers

Hi, When I had a similar situation, I checked the following things to synchronize the results: 1. The output I get in VDP Admin Tool matches with the data in the datasource or not. 2. I18n setting of VDP server. You can check the locale of VDP server by navigating to Administration -> server configuration -> Default i18n 3. Locale settings of Admin Tool. You can check the Admin Tool settings navigating to Tools -> Admin Tool preferences-> Locale. If you want to modify the output of the datetime field, I suggest you to follow the [Datetime processing functions](https://community.denodo.com/docs/html/browse/7.0/vdp/vql/appendix/syntax_of_condition_functions/date_processing_functions#) section of VDP VQL Guide. Hope this helps!
Denodo Team
23-10-2019 19:12:57 -0400
Hello, Thanks so much for the information. I am still rececving the error.
user
24-10-2019 08:43:54 -0400
Hi, If you are a customer, I suggest you to open a support case on our Support site to review the issue in detail. Hope this helps!
Denodo Team
04-11-2019 13:50:34 -0500
You must sign in to add an answer. If you do not have an account, you can register here