JDBC Connection to SQL Server Express - URI

Running Denodo Express VDP on my laptop. Got SQL Express installed and loaded with AdventureWorks DW 2014 data. What would be the URI if this is the case? I am trying to connect via JDBC using the following URI: jdbc:jtds:sqlserver://IA-EME/SQLEXPRESS/AdventureWorksDW2014 Where server name = /IA-EME/SQLEXPRESS Where database name = AdventureWorksDW2014 It is generating an Error > "Unable to establish connection: connection error: Connection timed out: connect" Appreciate the help. Thanks in advance
user
15-04-2019 10:44:27 -0400

3 Answers

Hi, Generally when I am creating a JDBC connection to connect a SQL server, the Database URI looks like this: jdbc:jtds:sqlserver://host:port/database, where the host is localhost, port is 1433. According to me, you don’t need to specify SQLEXPRESS in the host name. Your error message, > connection error: connection timed out: connect looks like a network issue to me, for more information on this, please refer to the previously answered question [here.](https://community.denodo.com/answers/question/details?questionId=9060g000000XdOhAAK&title=Getting+Connection+TimeOut) Hope this helps!
Denodo Team
16-04-2019 19:04:55 -0400
Hi, I did as recommended jdbc:jtds:sqlserver://localhost:1433/AdventureWorksDW2014 however.. I still get the error > Unable to establish connection: Network error IOException: Connection refused: connect I am not making any remote connection as the SQL Express is installed on the same laptop. Thanks
user
22-04-2019 23:34:20 -0400
Hi, I got the same error while I was configuring my SQL Server with Denodo Express. You might want to enable TCP/IP protocol in SQL Server Configuration Manager and also make sure that your firewall is not blocking the allowed port for TCP/ IP connections. Hope this helps!
Denodo Team
29-04-2019 19:00:03 -0400
You must sign in to add an answer. If you do not have an account, you can register here