You can translate the question and the replies:

unknown odata version 3.0

Hi, We have been able to successfully connect to the SharePoint lists as data sources using the Denodo-odata2-custom-wrapper. Recently when we tried to connect to one of the SharePoint lists from the same tenant we are getting an error **There was an error while creating this base view: Error while executing custom wrapper method 'getSchemaParameters': Unknown ODataVersion 3.0** What can be the possible solution to this? What if we use the Denodo-odata4-custom-wrapper to connect to the SharePoint list? If we install the new odata4 wrapper, what will be the affect on the previuosly connected SharePoint lists? Will there be any abnormality for the older connections? Please provide the help. Thanks.
user
03-05-2019 08:31:13 -0400

1 Answer

Hi, As it can be seen on the Denodo Connects page in the Denodo OData 2 Custom Wrapper description, OData Version 3.0 is only partially supported by this wrapper. I would make sure that Denodo is updated to the latest version and the latest Denodo OData 2 Custom Wrapper (20180329) is being used. I would also make sure if the OData version of sharepoint hasn’t changed. You can find ways to connect to Share point in [this](https://community.denodo.com/kb/view/document/Microsoft%20SharePoint%20as%20data%20source?category=Data+Sources) document. If you are a Denodo Customer, you can probably open a support case regarding this problem. Hope this helps!
Denodo Team
07-05-2019 17:13:53 -0400
You must sign in to add an answer. If you do not have an account, you can register here