GET_CATALOG_EFFECTIVE_PERMISSIONS ()

Is there another way to see the data in this procedure GET_CATALOG_EFFECTIVE_PERMISSIONS? I use select * from GET_CATALOG_EFFECTIVE_PERMISSIONS and get error 'Finished with error: View 'get_catalog_effective_permissions' not found'. This statement is running in a v7 environment.
user
12-12-2018 16:44:33 -0500

3 Answers

Hi, I faced the same error and it was because I was using the older update. Try upgrading to the latest version of Denodo 7.0 (update-20181011). This is a new feature and is added in the latest release of Denodo v7. I referred to [get_catalog_effective_permissions](https://community.denodo.com/docs/html/browse/6.0/vdp/vql/stored_procedures/predefined_stored_procedures/get_catalog_effective_permissions) section VQL guide to understand the syntax Hope this helps!
Denodo Team
13-12-2018 17:09:32 -0500
Hi Denodo team, We are in the latest version of 7.0 20181011 and I still get the error
user
13-12-2018 18:23:30 -0500
Hi In order to run it without any error you must enter the input values. 1) username is mandatory 2) database name is optional: if null, the procedure returns all the elements over which the user has privileges. In your case the query will be select * from GET_CATALOG_EFFECTIVE_PERMISSIONS (input_username : text,input_database_name : text) If the issue persists and you have a valid support user account, you may raise a support case on the Denodo Support Site so that it can be evaluated by the Denodo Team. Hope this helps !
Denodo Team
21-12-2018 13:38:34 -0500
You must sign in to add an answer. If you do not have an account, you can register here