You can translate the question and the replies:

SSL connection from PostgreSQL to Denodo 7 Solution Manager metadata

I have installed Denodo 7 Solution Manager with a postgresql db for the Solution Manager metadata which worked just fine but now I need to SSL the connection using certificates. I have the my server.crt, server.key and ca_bundle.crt in the data directory. Also in my pg_hba.conf: hostssl denodo denodouser serverhost cert When I try to start the License manager I get: Connection to serverhost:4432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
user
30-01-2019 16:25:40 -0500

1 Answer

Hi, I would perform the following tasks to verify the connection between Denodo Solution Manager and SSL-enabled PostgreSQL database : * Check whether the PostgreSQL database “**public key**” is imported in <DENODO_SOLUTION_MANAGER_HOME> * Ensure that the PostgreSQL database is listening to the correct port, which can be cross-verified in **postgresql.conf file**. * Also, check if the PostgreSQL connects with other SSL enabled JDBC clients. You can have a look at the “[Importing the Certificates of Data Sources (SSL/TLS Connections)](https://community.denodo.com/docs/html/browse/7.0/platform/installation/postinstallation_tasks/postinstallation_tasks_in_virtual_dataport/importing_the_certificates_of_data_sources_ssl_connections#importing-the-certificates-of-data-sources-ssl-tls-connections)” section and “[Enable SSL/TLS Connections in the Denodo Platform Servers](https://community.denodo.com/docs/html/browse/7.0/platform/installation/postinstallation_tasks/enable_ssl_connections_in_the_denodo_platform_servers/enable_ssl_connections_in_the_denodo_platform_servers#enable-ssl-tls-connections-in-the-denodo-platform-servers)” section under the Denodo Platform Installation Guide. If the problem persists, and you have an active support account, you could open a [support ticket](https://support.denodo.com/). Hope this helps!
Denodo Team
31-01-2019 07:23:15 -0500
You must sign in to add an answer. If you do not have an account, you can register here