You can translate the question and the replies:

Full Caching in Denodo Express

I'm trying to enable caching on a view that I have created based off of a JDBC connection to a SQL server. I'm using Denodo express and when I try to turn on full caching, i get the following error: Error loading jdbc data source 'vdpcachedatasource'. Any thoughts on how to get around this?
01-03-2019 10:30:33 -0500

3 Answers

Hi, For this situation, I would configure the cache in the server level, before configuring it in the view level, To configure the cache in the server level, * Turn *ON* the cache in the Server Configuration dialog under Administration menu in the Admin Tool (Administration > Server Configuration > Cache). * Configure the Cache Data Source in the Connection tab and test the connection. Have a look at [Configuring the cache]( in the Virtual DataPort VQL Guide, for more information. Hope this helps.
Denodo Team
04-03-2019 07:39:06 -0500
Once I successfully setup the server side, when I try and turn on full caching on the view I've created, I receive the following error: Error modifying view: View names not available What does this mean?
05-03-2019 10:30:04 -0500
Hi, Firstly, I would ensure that the cache data source test connection works fine at the server level. Then, in order to troubleshoot this error, I would enable the below logger category with debug level and refer the **vdp.log** file located under <DENODO_HOME>/logs/vdp to get more details about the error prompted in Virtual DataPort. Execute the below predefined stored procedure in the VQL shell of Virtual DataPort Administration Tool, to enable the logger category as mentioned above: `CALL LOGCONTROLLER(‘com.denodo.cache’,’debug’)` For more details, refer to the similar community question [Exalsol as Cache DB]( Hope this helps!
Denodo Team
12-03-2019 08:35:16 -0400
You must sign in to add an answer. If you do not have an account, you can register here