You can translate the question and the replies:

Data calalog giving page not found 404 error

Hi All, I have started the denodo platform services in below sequence and all services are running except data catalog and unable to open the http://hostname:9090/denodo-data-catalog/ URL, getting page not found 404 error. I can login in VDP admin tool and web scheduler https://hostname:9090/webadmin/denodo-scheduler-admin/login URL. Help me to resolve the below data catalog log error. Sequence service started : vqlserver_startup.sh arnindexserver.sh arn_webadmin_startup.sh webcontainer.sh datacatalog_startup.sh scheduler_webadmin_startup.sh Data catalog Log error : 4770 [RMI TCP Connection(2)-127.0.0.1] ERROR 2020-07-07T11:25:09.203 Info [] - Error obtaining license (1/3). Retrying in 5000 ms. Error retrieving data from 'http://localhost:10091/getLicense?nodeIp=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2C10.60.10.69%2C0%3A0%3A0%3A0%3A0%3A0%3A0%3A1%25lo%2C127.0.0.1&bootId=3d7ffd17-fe5d-41ad-9ee5-3c0d5acb4e83&hostDomainName=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2Cip-10-60-10-69.eu-central-1.compute.internal%2Clocalhost%2Clocalhost&nProcessor=4&versionProduct=7.0&versionUpdate=202005041537&port=9090&product=VDP_DATA_CATALOG&lastBootId=&installId=7f1b3e8c-97d0-48de-b036-cab2183b8db6'. HTTP error code: 400.\nDetail: Incorrect Product 9795 [RMI TCP Connection(2)-127.0.0.1] ERROR 2020-07-07T11:25:14.228 Info [] - Error obtaining license (2/3). Retrying in 5000 ms. Error retrieving data from 'http://localhost:10091/getLicense?nodeIp=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2C10.60.10.69%2C0%3A0%3A0%3A0%3A0%3A0%3A0%3A1%25lo%2C127.0.0.1&bootId=3d7ffd17-fe5d-41ad-9ee5-3c0d5acb4e83&hostDomainName=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2Cip-10-60-10-69.eu-central-1.compute.internal%2Clocalhost%2Clocalhost&nProcessor=4&versionProduct=7.0&versionUpdate=202005041537&port=9090&product=VDP_DATA_CATALOG&lastBootId=&installId=7f1b3e8c-97d0-48de-b036-cab2183b8db6'. HTTP error code: 400.\nDetail: Incorrect Product 14809 [RMI TCP Connection(2)-127.0.0.1] ERROR 2020-07-07T11:25:19.242 Info [] - Error obtaining license (3/3). Error retrieving data from 'http://localhost:10091/getLicense?nodeIp=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2C10.60.10.69%2C0%3A0%3A0%3A0%3A0%3A0%3A0%3A1%25lo%2C127.0.0.1&bootId=3d7ffd17-fe5d-41ad-9ee5-3c0d5acb4e83&hostDomainName=fe80%3A0%3A0%3A0%3Ac3%3A8fff%3Afe81%3Ab2aa%25eth0%2Cip-10-60-10-69.eu-central-1.compute.internal%2Clocalhost%2Clocalhost&nProcessor=4&versionProduct=7.0&versionUpdate=202005041537&port=9090&product=VDP_DATA_CATALOG&lastBootId=&installId=7f1b3e8c-97d0-48de-b036-cab2183b8db6'. HTTP error code: 400.\nDetail: Incorrect Product 14811 [RMI TCP Connection(2)-127.0.0.1] ERROR 2020-07-07T11:25:19.244 LicUtil [] - com.denodo.a.a.h: Remote license not found. Incorrect Product 14811 [RMI TCP Connection(2)-127.0.0.1] ERROR 2020-07-07T11:25:19.244 EventContextListener [] - License not found

4 Answers

Hi, This could be an issue related with the updates you have in Denodo Platform and Solution Manager. Make sure both have updates installed and are on the Updates 20181011 or later. If not, I would suggest doing the update and testing again. Hope this helps.
Denodo Team
08-07-2020 00:54:10 -0400
Isn't the error showing unable to connect to correct License. Data Catalog service will not start without License validation
user
08-07-2020 13:37:06 -0400
Hi, There could be multiple reason for this error and it requires in depth analysis to find the root cause. I would first start with checking if both VDP Server and Solution Manager are on the same update which is also Updates 20181011 or later. If still the same error occurs, will try to find more information on the log files. Also, Data catalog do not particularly require a configuration in Solution Manager to get the license, but there is an option of[ Creating a Data Catalog Server](https://community.denodo.com/docs/html/browse/7.0/solution_manager/administration/servers/creating_servers/creating_servers#creating-servers) as well in Solution Manager and in case you have completed that, you might want to recheck that configuration as well. Hope this helps!
Denodo Team
21-07-2020 02:42:14 -0400
The log is clearly showing that the License did not match - it says incorrect Product. You do have License there because VDP Server is starting and you can get to VDP Admin tool. But Catalog does not seem to match that License. That needs to be investigated. (If the Catalog service is not started, it will give HTTP404, so that Service needs to start first.) By the way, is this problem on Denodo 8 or Denodo 7?
user
21-07-2020 10:48:32 -0400
You must sign in to add an answer. If you do not have an account, you can register here