You can translate the question and the replies:

Virtualization of my data warehouse snowflake

Hi, I created a unified view of my datasource of snowflake. When i make an update in my table on snowflake, i saw that the change is made also on my view on denodo. And i don't want the update appear in the view on denodo. Is it possible ? Thank you
user
15-07-2020 05:18:44 -0400

3 Answers

Hi, The answer for your question depends on what you mean by updating your table. The view created on the Denodo Virtual DataPort are representational and real time. If you mean that you are inserting/updating records in your Snowflake data source then, whenever a query is executed Denodo connects in real time to your Snowflake source and pulls the data in the most cost-effective way. If you do not wish to get the real time data, you could cache the view using [Full Mode](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/cache_module/cache_modes/full_mode). With this option, whenever you query this view, the data of the view is based on what you have cached and is always retrieved from the cache database instead of from the source. In case, if you have made any changes structurally (for eg, adding new fields ) on your table in your Snowflake source, then to propagate the changes in Virtual DataPort, it is required to use the [‘Source refresh’](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/creating_data_sources_and_base_views/source_refresh/source_refresh#source-refresh) option for a view so that changes in the schema will be reflected. If you do not source refresh the view, the schema will not be updated in Virtual DataPort. I suggest you to refer the aforementioned documentations for more information. Hope this helps!
Denodo Team
15-07-2020 06:58:16 -0400
Thank you for your answer. I created a JDBC job in the scheduler. ![https://www.facebook.com/photo?fbid=10223615516443748&set=a.1652387197316](http://) It never running. The state still "NOT_RUNNING"
user
15-07-2020 22:07:21 -0400
Hi, The image you have attached is not visible. However, based on your comment, I can understand that you have a Scheduler Job and it is currently in a State of "NOT_RUNNING". For this scenario, I would suggest you to perform the following checks: * Ensure to click "Start" button to run the job. The state of the job will be changed to RUNNING. Once the job gets completed, it will be back to "NOT_RUNNING" state. * If the job has been scheduled to be executed at a particular time using a cron expression, then the job will be in a "NOT_RUNNING" state. The job will run only at the specified time. * Finally to debug further, check the Job report and 'scheduler.log' file found in "<DENODO_HOME/logs/scheduler" folder. You can have a look at the [Jobs](https://community.denodo.com/docs/html/browse/7.0/scheduler/administration/creating_and_scheduling_jobs/jobs/jobs) section of Scheduler Administration Guide for more information. Hope this helps!
Denodo Team
23-07-2020 05:35:17 -0400
You must sign in to add an answer. If you do not have an account, you can register here