You can translate the question and the replies:

ERROR: 666 : Memory quota too low for aggregation

ERROR: 666 : Memory quota too low for aggregation i am getting this error while running the view, all the memory setting are correct as per the denodo guideline. Please suggest
user
08-09-2020 21:57:28 -0400

1 Answer

Hi, I understand that executing a view results in the error “ERROR: 666 : Memory quota too low for aggregation” and you also have configured the memory settings as per the Denodo guides. Based on this error, I believe that the view is complex and which is why the data source is overloaded during query execution. In your case, to understand if the issue is caused by the data source, I would execute the delegated SQL sentence in the source system and check if the same error is returned. To obtain the SQL sentence, execute the view, then click on "Execution Trace" and select the bottom node. Then, go the right section and you will be able to see the SQL sentence that Denodo is executing at the Data Source. If this did not help, then I would recommend you to review your Swapping parameters further by verifying the section [Configuring the Memory Usage and Swapping Policy](https://community.denodo.com/docs/html/browse/latest/vdp/administration/server_configuration/configuring_the_memory_usage_and_swapping_policy/configuring_the_memory_usage_and_swapping_policy#configuring-the-memory-usage-and-swapping-policy). In addition, you could take a look at the various [optimization](https://community.denodo.com/docs/html/browse/8.0/vdp/administration/optimizing_queries/optimizing_queries#optimizing-queries) options available in the Denodo Platform which would help in improving the query performance. Hope this helps!
Denodo Team
09-09-2020 08:09:10 -0400
You must sign in to add an answer. If you do not have an account, you can register here