You can translate the question and the replies:

Denodo Scheduler Jobs

I have a scheduled job that runs 15 minutes after the hour, 24 hours a day. When a long running, heavy resource job is running at the same time, the scheduled job that runs 15 minutes after the hour does not complete before the next hourly execution of the scheduled job is submitted. The subsequent jobs are not queued and no error message is generated. When the job finally finishes, it executes the next scheduled job and by passes the missed jobs. Please advise, how to address the noted issue.
14-10-2020 22:51:53 -0400

1 Answer

Hi, Generally, when I have a Scheduler Job using huge amount of resources (Memory), I would increase the memory for the Scheduler server by performing the below steps: * Launch the Denodo Control Center with administrative privileges * Go to Configure > JVM Options * For Scheduler server: change '-mx1024m' to desired value. **For Example** : -mx4096m' .This will change the heap space from 1GB (1024MB) to 4GB (4096MB) * Click Ok and restart the Scheduler server. Additionally, in Scheduler Administration tool, I would also increase the threads for executing jobs concurrently. In order to do this, I would navigate to Configuration > Server Configuration > [Threads pool]( and modify the parameter Maximum number of concurrent jobs (for instance, Set it to 50).This allows Scheduler to use more threads for executing jobs concurrently. Further, for more inform about the misfire of the triggered jobs I would check the Scheduler.log file located in <DENODO_HOME>/logs/scheduler folder. In case, if you still need help and if you are a valid Support User, you may open a Support Case at the Denodo Support Site and the Support Team will help you. Hope this helps!
Denodo Team
15-10-2020 07:52:47 -0400
You must sign in to add an answer. If you do not have an account, you can register here