You can translate the question and the replies:

New Role, admin feature errors with hyphen

Seeing some strange behavior as an admin in my denodo Rolemangement screen. when I try to create a rolename with hyphens, ie "rolename-john' I get a 'Verify the folliwing issue > Name: Invalid field name." I know it used to work as we have roles already there with hyphens. quite bizzar, but I need these roles to have hyphens.
23-10-2020 15:53:48 -0400

1 Answer

Hi, You could create role names with hyphens in 2 ways. 1. Change the identifiers charset to Unicode in the Administration --> Server configuration--> Identifiers charset menu option. Unicode allows to use any character in the names of the elements (views , roles users) including hyphens and you would be able to create roles with hyphens in the name from the Administration --> Role management menu. To know more about [identifiers charset]( and its implications you can take a look at Identifiers charset Virtual DataPort guide. 2. Create Roles using the “Create Role” VQL statement by enclosing the role name in double quotes in VQL Shell. Ex:- Create Role “role-sales” grant connect to sales_db. Note that if the identifiers charset is set to Restricted then you would always have to put the role name in double quotes in VQL statements. Ex:- Desc “role-sales”. You can take a look at [Creating Roles]( Virtual DataPort guide for details on creating roles. Hope this helps.
Denodo Team
27-10-2020 03:49:53 -0400
You must sign in to add an answer. If you do not have an account, you can register here