You can translate the question and the replies:

What is the Java version requirement for denodo-vdp-server.jar for Custom Wrapper development

We have denodo 7 running java version "1.7.0_261" OpenJDK Runtime Environment (amzn-2.6.22.1.83.amzn1-x86_64 u261-b02) OpenJDK 64-Bit Server VM (build 24.261-b02, mixed mode) Tried to compile a sample Custom Wrapper using Java7 (major version 51) and got warnings that denodo-vdp-server.jar requires Java8 (major version 52). We will upgrade our denodo 7 to denodo 8 with openjdk 11.0.8. Does denodo-vdp-server.jar support openjdk 11.0.8?
user
27-10-2020 13:51:10 -0400

1 Answer

Hi, The warning message you are getting due to the incorrect Java version because **Denodo Platform 7.0** supports the **Java version 8**. Hence, when you compile a sample Custom Wrapper with Denodo Platform7.0, then you need to make sure that you are using Java version 8.0 in order to avoid that warning message. If you are migrating to **Denodo Platform 8.0**, then you need to make sure that you are using Java version 11 while compiling the Custom Wrapper because it supports **Java version 11**. To get more information, you can refer to the **README** file locate at <DENODO_HOME>\samples\vdp\customWrappers. For more information, you could also refer to the KnowledgeBase article [Java versions supported by the Denodo Platform](https://community.denodo.com/kb/view/document/Java%20versions%20supported%20by%20the%20Denodo%20Platform?category=Installation+%26+Updates). Hope this helps!
Denodo Team
28-10-2020 06:01:25 -0400
You must sign in to add an answer. If you do not have an account, you can register here