You can translate the question and the replies:

Refresh token not fetched when connecting to Azure Blob Storage

Hi all, I followed the steps accoring to the Denodo Data sources guide (https://community.denodo.com/kb/view/document/How%20to%20connect%20to%20Azure%20Blob%20Storage%20from%20Denodo) and obtained the OAuth2.0 credentials. Everything worked fine but after clicking "ok", in the next window the "Refresh token" is missing - while the filed "Access token" and "Token endpoint URL" are filled and the "Access token expires in" field is updated with the value 3599). In the folliwing I cannot connect to the data source. Is this a wrong configuration in my Azure Portal? Where can I change the settings in order to retrieve a refresh token? Thank you very much for your support, Matthias ![RefreshToken](C:/Users/dvAdmin.dvClient/Desktop/RefreshToken.jpg)

3 Answers

Hi, I tried following the steps in the KB article and everything worked successfully. In your case, I would check the following: * Vdp admin and server are in the same update * Look for the log files to find any errors * Try connecting from external client like Postman We suggest you to open a support case if you are a valid support user, and support team can help you better. Hope this helps!
Denodo Team
27-11-2020 11:18:23 -0500
Hi Team, I am facing the similar issue. Every thing is set up correctly in denodo conenction side. Is something missing at the Azure Blob side? Everything worked fine but after clicking “ok”, in the next window the “Refresh token” is missing - while the filed “Access token” and “Token endpoint URL” are filled and the “Access token expires in” field is updated with the value 3599). The connection is not working for me either. Any help would be appreciated!! Thanks!
user
08-10-2021 17:23:13 -0400
Hi, I would follow the steps mentioned in the work-around described [here](https://community.denodo.com/answers/question/details?questionId=9064u000000HA6XAAW&title=How+to+connect+to+Azure+Blob+Storage+from+Denodo). If you still have problems using OAuth 2.0 authentication and you have a valid support account, you can open a new case in the [Support Site](https://support.denodo.com) so the Denodo team can help you. Hope this helps!
Denodo Team
22-10-2021 15:46:25 -0400
You must sign in to add an answer. If you do not have an account, you can register here