You can translate the question and the replies:

Same Query Returns different number of records in Baseview and Derivedview

Hello Team, I have created 2 baseview(bv_studies, bv_results) of dfferent sources in Denodo. After that, I have created one derived view(dv_final) from these baseview with Inner Join. I am passing 2 parameters to bv_studies. Now the problem is, while i am executing derived view(dv_final) it is showing less number of records(114 rows) than the expected number of records(149 rows). I found the problem, when i individually executed bv_studies it returned 106100 rows whereas i checked the execution trace of derivedview(dv_final) and at there bv_studies returned 101908 rows. Everytime the count in execution trace of derived view for that baseview is different.(Sometimes it got 101908 sometimes 98996 and sometimes 104430 etc for same parameters) and also state is ENOUGH_ROWS_RETRIEVED. I am not using cache. i also tried with Do not use Cache option. I am passing same paramteres while executing both the queries. I checked in execution trace that parameters are perfectly passed in both the queries. Can you please help me with this issue? Thanks in Advance
user
10-02-2021 10:38:01 -0500

4 Answers

Hi, The** [ENOUGH_ROWS_RETRIEVED](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/appendix/execution_trace_information/execution_trace_information) **state obtained from the execution trace indicates that the node of a query was stopped because no more rows from this node were needed to complete the request. In this scenario, I would check if the Join type, Join method, Join order set and the filter conditions specified for the derived view are correct. I would also try disabling the [Automatic Simplification of Queries optimization](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/optimizing_queries/automatic_simplification_of_queries/automatic_simplification_of_queries#automatic-simplification-of-queries) option for this view by executing this view with the **[CONTEXT clause](https://community.denodo.com/docs/html/browse/latest/en/vdp/vql/queries_select_statement/context_clause/context_clause#context-clause)** in the VQL query like: Select * from <view_name> context ('simplify'='off'); to avoid the Execution Engine to simplify the actual query execution You can take a look at [Creating Join Views](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/creating_derived_views/creating_join_views/creating_join_views#creating-join-views) and [Optimizing Join Operations](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/optimizing_queries/optimizing_join_operations/optimizing_join_operations#optimizing-join-operations) section of the Virtual DataPort Administration Guide for more information. Hope this helps!
Denodo Team
11-02-2021 07:44:06 -0500
Hello Team, The question here is why it is going to the state of ENOUGH_ROWS_RETRIEVED eventhough there are more records available. The issue here is not related to Join Type,Method or Order. The baseview used in derived is not taking all records hence i am getting less records in derived view. I tried Context clause in VQL (simplify=off) but it doesn't solve my problem.
user
11-02-2021 08:18:45 -0500
Hello Team, Is there any update??
user
16-02-2021 03:04:55 -0500
Hi, If I come across this error, I would check the **vdp.log** file under the directory **“<DENODO_HOME>\logs\vdp”** and check if there is any error causing this **ENOUGH_ROWS_RETRIEVED** state. If the issue persists and if you are a user with valid support access then you can raise a support case in **[Denodo Support Site](https://support.denodo.com/)** so that our support team can help you. Hope this helps!
Denodo Team
19-02-2021 07:29:38 -0500
You must sign in to add an answer. If you do not have an account, you can register here