You can translate the question and the replies:

How to connect to Azure Blob Storage from Denodo

Hi Team, I am working on denodo 8.0 and tryign to read a delimited file over HTTP from Azure blob storage. Can you please let me know what need to go here for configuring HTTP header? How to get storage service version number? And what will be the value for thr header variable name? Configure the “HTTP Headers”. Note: We need to specify the storage service version number(using HTTP Header x-ms-version) to recover the files from Blob storage, if we are using the AD/Oauth2.0 to authenticate the connection, the version number should be later than 2017-09-11 (i.e, the current version 2018-03-28). Thanks!
user
08-10-2021 14:35:58 -0400

6 Answers

Hi Team, I added " x-ms-version" as a variable and assigned the value as 2018-03-28 and its not complaining. I am not sure how and where this variable is used? Can you please explain this? Is this a madatory configuration? Also after settign the OAuth authentication excel connection for reading excel file stored on Azure blob is not working for me. ANy guidance would be appreciated. Issue: Denodo cannot read files stored on Azure blog over HTTPs. Azure container is set up as a private end point. Error: Message returned by the server: <?xml version="1.0" encoding="utf-8"?><Error><Code>PublicAccessNotPermitted</Code><Message>Public access is not permitted on this storage account. RequestId:0a498287-101e-0066-5b6d-bc9131000000 Time:2021-10-08T17:53:37.2012209Z</Message></Error>
user
12-10-2021 11:57:26 -0400
Hi, I used this [Knowledge Base guide](https://community.denodo.com/docs/html/document/denodoconnects/8.0/en/Denodo%20Distributed%20File%20System%20Custom%20Wrapper%20-%20User%20Manual#h.ifumpzhkbidv) to create a connection between Denodo Platform and Azure Blob Storage and it worked for me. It had all the information required to establish a connection with Azure Blob. Hope it helps!
Denodo Team
13-10-2021 04:40:18 -0400
Hi Team, We are able to connect to Azure Blob Storage from Denodo platform 8.0 using the Denodo Distributed File System Custom Wrapper method but not able to connect using the HTTP Client method. Issue: Denodo cannot read files stored on Azure blog over HTTPs. Azure container is set up as a private end point. Any pointers/suggestions? Error: Message returned by the server: <?xml version=”1.0” encoding=”utf-8”?><Error><Code>PublicAccessNotPermitted</Code><Message>Public access is not permitted on this storage account. RequestId:0a498287-101e-0066-5b6d-bc9131000000 Time:2021-10-08T17:53:37.2012209Z</Message></Error>
user
13-10-2021 12:18:22 -0400
For other it might be useful : Denodo is unable to connect to privaet end point with OAuth. We tried SAS token and then it worked fine. Its a work around but it works. We are still following up with denodo to see if its a platform issue.
user
20-10-2021 12:16:42 -0400
Steps followed: In the client applications in “Expose an API”. To do that follow the below steps: 1. Click on “Add a client application” 2. In the Client ID section, you can provide the client ID (Application ID) from the Overview page of the application. 3. Then select the below generated scope and click “Add application”. Also, We have seen the error “Public access is not permitted on this storage account” in your Virtual DataPort Administration tool while connecting Azure blob storage to Denodo, this is because you have disabled the Blob public access, you can still connect to the CSV file when you have disabled the blob public access by generating the blob SAS URL. 1. Please navigate to your CSV file in your container from the Azure portal. 2. There will be five tabs Overview, Versions, snapshots, edit and Generate SAS 3. Please select the option “Generate SAS” 4. Give the necessary privileges and other information and click on “Generate SAS token and URL” to generate a “Blob SAS URL”. 5. Please use the Blob SAS URL in your Virtual DataPort Administration tool and place it in the URL section under the configuration tab. This will authenticate the connection.
user
20-10-2021 12:18:05 -0400
Hi, I also encountered the same error message after disabling Blob public access in Azure. I resolved the issue by generating a Blob SAS URL to use in my data source configuration, just like the steps you listed. Hope this helps!
Denodo Team
20-10-2021 21:54:39 -0400
You must sign in to add an answer. If you do not have an account, you can register here