You can translate the question and the replies:

Deployment Error: Error checking if token authentication is configured.

Hi Team, I am unable to deploy with the following error: *Error checking if token authentication is configured.* Note: 1. All configs in platform control center have been done with Security aunthentication token details (host name and port of solution manager) 2. SSO configuration properties file have been updated with valid SSO url 3. HTTPS has not been defined so SSL/TLS has not been checked in control center. 4. Validations work fine and there are no errors 5. Server authentication in VDP under server management is checked and denodo token authentication is enabled can you please help me resolve the issue.

3 Answers

Hi, I would make sure to follow the directions for [Configuring the Connection to the Security Token Server from the Denodo Platform](https://community.denodo.com/docs/html/browse/8.0/en/solution_manager/administration/denodo_security_token/denodo_security_token#configure-the-connection-to-the-security-token-server-from-the-denodo-platform). In particular, making sure that the file conf\SSOConfiguration.properties from theVirtual DataPort installation contains the properties sso.url = http://<solution-manager-host>:<solution-manager-webcontainer-port>, and sso.token-enabled = true. <solution-manager-host> is the hostname where the Solution Manager is running. Finally, after making the above changes, make sure to restart all affected servers for the changes to take effect. Hope this helps!
Denodo Team
02-11-2021 15:35:21 -0400
Hi, the configuration was already done but the issue is still not resolved. Error in logs: *Caused by: com.denodo.vdb.vdbinterface.common.connection.VDBConnectionException: Connection error: Check the host name and port number are correct, and that client and server belong to the same Denodo major version. Server host name parameter is mandatory* My SSOConfiguration.properties file contents: sso.url=http://localhost:19090 sso.enabled=true sso.token-enabled=true Note:the installation in in a local machine. I have provided the ip of localhost and checked as well but the issue is not resolved.
user
08-11-2021 05:32:06 -0500
Hi, I would try replacing localhost with the machine name/host name to validate if the error is because of the current value which is localhost. I would also look further into the logs\solution-manager\solution-manager.log file as there could be more information in that error message. If you still face this issue and you have a valid support user, you can open a support case on [Denodo Support Site](http://support.denodo.com) so that our support team can help you. Hope this helps!
Denodo Team
08-11-2021 16:13:55 -0500
You must sign in to add an answer. If you do not have an account, you can register here