You can translate the question and the replies:

Distinct clause issue

Hi Team, I'm using Denodo 7.0 Facing issue with Distinct function. we have a join view which is working fine without Distinct clause. When we apply Distinct in code and saved, we getting error while executing which says something like ' 75576 limit exceeds 65536'. Not sure how it worked without distinct. Please help.
02-12-2021 13:13:36 -0500

1 Answer

Hi, I would troubleshoot this scenario with the following steps * Ensure that the data type length of the underlying data source and VDP platform are in sync. You can find more information in this [community link]( Default ‘text’ field length in Denodo is 65536 and you can manually increase the size of the text field in VDP as per the data length as available in source. For more information on editing the length of the field manually, you could take a look at the Viewing schema [Source Type Properties]( section under the Virtual DataPort Administration Guide. I would modify the length accordingly and execute in VDP without any row limit and verify the result. * Check the allowed Record Size limit as defined by the data source by checking its official documentation * Obtain the SQL sentence from the “Execution Trace” as provided in link above and execute the query in datasource without applying any query limit to check if same error is returned in datasource * Execute the join view with reduced number of columns with distinct clause and verify the status of query result If you still need help and if you are a valid support user then you can raise a support case on [Denodo Support Site]( so that our support team can help you Hope this helps!
Denodo Team
03-12-2021 08:12:37 -0500
You must sign in to add an answer. If you do not have an account, you can register here