You can translate the question and the replies:

Source Refresh not working on web Virtual DataPort

Hi, I have some columns that didn't change in my source, but they weren't in my base view because I didn't need them before. But now I need so I want to update my baseview and add that columns. A coleague of mine has the virtual dataport **application** and when he click on "Source Refresh" a dialog is opened with all the available columns of the source for him to choose so he can add all the columns that he wants. But I only have access to the **web** virtual dataport and there when I click on "Source Refresh", the buttoms "Source Refresh" and "Drop" fade out, as something is being processed (and there is a little wheel turning), but they just fade in again and nothing happens, no dialog! I tried other source that had changes between the source columns and base view and with that source a dialog opened but it shows me only the changes in the columns that were already in the base view and offers me just 2 options, keep the current base view or overwrite the new changes. But I also had no way to add other columns. Why the behaviour of the "Source Refresh" buttom is different between the two versions of virtual dataport? Is there any other way for me to add the columns that I want? I don't know the exactly name of each column, so I need a way to see all the available columns of the source to decide wich column I want. Thanks
17-02-2022 06:48:47 -0500

1 Answer

Hi, Generally, the [Source Refresh]( feature in the Virtual DataPort Administration Tool/Web Design Studio enables the user to sync the changes from the datasource to Virtual DataPort and If there are no changes at the underlying data source, it will retain the current information of the view. I was able to reproduce the behavior you have experienced in Design Studio when I tried to perform “Source Refresh” to a view with the user who has only “Connect” and “Metadata” privileges. In order to resolve this, I would ensure that “Write” privilege is also assigned to the user account so that I could refresh and modify the base view. Regarding your other scenario, I believe there are no changes at the underlying data source such as addition of new columns and that is the reason you might be getting the current information. You can refer to the [Types of Access Rights]( section of the Virtual DataPort Administration Guide which elaborates more on the privileges and access rights to the Virtual DataPort. Furthermore,if you need more assistance on this topic and you are a valid Support user, you can create a Support case on the [Denodo Support Site]( so that the Support team can assist you further. Hope this helps!
Denodo Team
18-02-2022 07:25:35 -0500
You must sign in to add an answer. If you do not have an account, you can register here