You can translate the question and the replies:

'[Unexpected error creating a connection: Pool not open]' - Scheduling VPDcache job

I am scehuling the VDPcache job, I can select the datasource, views to be cache from the denodo db. I have added two views by choosing load process for each one as 'Non-incremental' . While manually started the job it end up with error '[Unexpected error creating a connection: Pool not open]' I can run the same as VDP job with query parameter with no error. Could you help on finding for the reason for error and solution. Report: 0 Report for job 'cache_job': Start Time: Wed Mar 10 16:58:33 CST 2021 End Time: Wed Mar 10 17:00:43 CST 2021 Datasource (extraction): null General Errors: [] Initialization Errors: [] Handler Errors: {} General Warnings: [] Retry count: 0 Should re-execute job: false ServerInfo: null Extracted Docs: 806090 Extractor Errors: [] Extractor Warnings: [] Query: select * from db.view_name CONTEXT('cache_preload'='true', 'cache_wait_for_load'='true', 'cache_return_query_results'='false', 'cache_invalidate'='all_rows', 'cache_atomic_operation'='true') TRACE Load Process Name: db.view_name Cached Docs: 0 Cache Errors: [Unexpected error creating a connection: Pool not open] Execution Errors: {} Execution Warnings: {} Execution Success: {} Combinations: null Load Processes Reports:
user
10-03-2021 18:34:11 -0500

11 Answers

Hi, Going through the question, I believe the error** Unexpected error creating a connection: Pool not open** might be due to the following reasons: * First is that, queries are attempting to access the cache while the cache configuration is in the process of being altered. * Secondly, in case if I have configured an external cache database, it might be down or inaccessible at that time, so Denodo could not be able to access it. You can refer to the [VDPCache Extraction](https://community.denodo.com/docs/html/browse/latest/en/scheduler/administration/creating_and_scheduling_jobs/configuring_new_jobs/vdpcache_extraction_section) section under the Scheduler Administration Guide for more information. Hope this helps !
Denodo Team
11-03-2021 07:34:40 -0500
Appreciate your response. I have checked, the cache db is up and running fine. Also I could see the records are getting added to the cache tables with valid status, but at last the job is failed with the error status '[Unexpected error creating a connection: Pool not open]' Can you please explain more on option 1 mentioned above? Beacuse I could not see any confiuration change, and I am getting this error all the time when I run the VDPCache job. Looking forward for your findings. Thank you,
user
17-03-2021 14:35:18 -0400
Hi, I believe the error **Unexpected error creating a connection: Pool not open** might be due to the Cache Maintenance is set **ON**. This means for every certain second, there will be a heavy load on your cache as delete operations are run. Due to this, when queries are attempting to access the cache, this could lead to problems with retrieving connections. Further, if any maintenance is happening, I would **disable** the "**Maintenance**" option under Administration > Server Configuration > Cache > General Settings of the Virtual DataPort Administration Tool. You can refer to the [Cache Maintenance Task](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/cache_module/cache_maintenance_task/cache_maintenance_task) section under Virtual DataPort Administration Guide for more information. Hope this helps !
Denodo Team
25-03-2021 07:36:28 -0400
Thanks for your response. I have tried the above mentioned option setting the cache maintenance to 'off' , but still getting the same error Pool not open. could you please provide if any alternative solution or any other parameter to be taken care. Still not able to schedule the VDP cache job. Thank you.
user
22-04-2021 11:09:45 -0400
Hi, Going through the question, the error **Unexpected error creating a connection: Pool not open **might occur if the connection pool is not available for the data source. For this scenario, I would ensure the Catalog name and Schema name given in the parameter **Specify custom catalog and schema** is correct by performing the following steps in the Virtual DataPort Administration Tool: * Open the cache datasource and go to Configuration > Read&Write tab. * Click the refresh button next to Specify custom catalog and schema. * In the drop down of Catalog select the **catalog**. * In the drop down of Schema select the **schema** and save the changes. Also, kindly **note** the name of the schema and catalog are selected from the drop down rather typing the values manually. Hope this helps !
Denodo Team
30-04-2021 07:06:15 -0400
Hello, We are having the same issue. It's been persistent for over 1 Hour. None of the suggestions above fixes this problem and its in our production enviroment. What is the root cause of the message?
user
11-06-2021 18:36:29 -0400
Hi, The error "**Unexpected error creating a connection: Pool not open**" might occur when there is a problem with a connection from the pool, or even maybe that the pool has been closed. For this scenario, I would check the Virtual DataPort database where this error occurs that use a different cache configuration than the server cache. This can be done by navigating to Administration > Database Management, select the Virtual DataPort database and click '**Cache**' in the Virtual DataPort Administration Tool. If the 'default configuration' option is not checked, then the Virtual DataPort database is using a different configuration. Also, I would check if the cache is **enabled** at server level from Administration > Server configuration > Cache and ensure the 'On' option is selected. Hope this helps !
Denodo Team
18-06-2021 01:59:01 -0400
Our Denodo is connected to an AWS PostgreSQL 9 RDS. Our Config is as stated in the manuals for Denodo 8.0
user
18-06-2021 10:46:30 -0400
Hi, I was able to schedule the VDP cache job successfully by following below check in the Virtual DataPort Administration Tool : * Catalog name and Schema name given in the parameter **Specify custom catalog and schema** is correct. For this scenario, you could set a higher log level such as **TRACE** and check the log file under the <Denodo_Home>/logs/ directory to find additional information regarding the error. Additionally, if you still need help and if you are a user with valid support access then you can create a support case in [Denodo Support Site](https://support.denodo.com/) so that our support team will assist you further. Hope this helps!
Denodo Team
25-06-2021 05:09:16 -0400
We started getting that error after I increased the connection pool for our cache from 20 to 30. VDP running on linux, cache data source is MS SQL Server Windows 2016. Cache jobs are all full cache. They would run and extract all the data but fail when they tried to load into cache. VDP service needed to be restarted after the size of the pool was changed.
user
31-08-2021 15:12:10 -0400
Hi, Generally, the Connection Pool configuration option located is to configure the parameters of the connections pool used to access the cache database. You can refer to the [Parameters of the Connection Pool of a JDBC Data Source ](https://community.denodo.com/docs/html/browse/8.0/vdp/vql/generating_wrappers_and_data_sources/creating_data_sources/jdbc_data_sources#parameters-of-the-connection-pool-of-a-jdbc-data-source)section under Virtual DataPort VQL Guide for more information. Hope this helps!
Denodo Team
09-09-2021 07:13:31 -0400
You must sign in to add an answer. If you do not have an account, you can register here