You can translate the question and the replies:

Unable to establish connection: IO Error: The Network adapter could not establish the connection - Denodo 8.0

I have the Denodo Quickstart virtual machine up and running on VirtualBox 6.1.18 I have followed the instructions regarding network adapter #2 configuration as provided and if i run command ip addr within the VM I can see that the adapter ip address is being used. The VDP is also up and running in Denodo 8.0 and i have succesfully logged in to the newly created denodo_training database and am in process of creating the first data source ds_web_orders. I have followed the instructions exactly as shown but the URL jdbc:oracle:thin:@ returns an error: Unable to establish connection: IO Error: The Network adapter could not establish the connection. I have also tried adding host name data-server in hosts file and replacing the ip address in the URL but get the same error whether using name or ip address If i try to ping data-server I also get the message Request timed out. Is there some other steps required that are not listed in the documentation that i have missed? Thanks in advance!
12-04-2021 10:21:17 -0400

3 Answers

Hi, When I faced the similar issue, I performed the following, * In the Virtual Machine Host network manager, add the new Host only network adapter #2 as indicated in the **Denodo Training QuickStart Virtual Machine - User Manual - <version>**. * Next, in the Virtual Machine settings for the Denodo Training Quickstart Virtual Machine, go to the **Network** menu option and set Adapter 2 to the new that is created and **disable the Adapter 1** which is enabled by default. * Now, start DQVM and login to find the IP address of the DQVM using the **ipaddr** command. * In Virtual DataPort Administration tool, create the [JDBC data source]( with the Database URI as** jdbc:oracle:thin:@<DQVM_IP_ADDR>:1521:xe**. Hope this helps!
Denodo Team
13-04-2021 06:52:36 -0400
Hi, i followed all the steps but it keeps showing me the same error. - I went to the network section and deactivated card 1 and put adapter # 2 on card 2. - when I started the virtual machine (DQVM) I get the IP On Virtual DataPort Administration Tool I put on URI -> jdbc:oracle:thin:@ - when I do the connection test I get this error "Unable to establish connection: IO Error: The Network Adapter could not establish the connection" - to verify that I can reach virtual machine IP I put on CMD as administrator "Ping" and it gave me as result "Pinging with 32 bytes of data: Request timed out." Thanks in advance!
14-04-2021 07:52:10 -0400
I had the same problem and followed the advice of the denodo team. The solution that worked for me was using another IP address. My QuickStart virtual machine runs on and I dont know why the second address didnt work for me but using the first adress was my solution.
19-01-2023 09:42:42 -0500
You must sign in to add an answer. If you do not have an account, you can register here