You can translate the question and the replies:

non-JRMP server at remote endpoint - Can't connect jconsole

Hello, When I try to connect to localhost:9997 using the jconsole I get an error: Connection failed: non-JRMP server at remote endpoint. I have TLS enabled. What might be wrong? Thank you
user
13-05-2021 11:26:13 -0400
code

1 Answer

Hi, Denodo supports connecting Monitoring Tools using the Java Management eXtension (JMX) standard, which includes JConsole. I am able to connect to this monitoring port, following the [Monitoring with a Java Extensions Agent](https://community.denodo.com/docs/html/browse/8.0/en/vdp/administration/monitoring_the_virtual_dataport_server/monitoring_with_a_java_management_extensions_jmx_agent/monitoring_with_a_java_management_extensions_jmx_agent#monitoring-with-a-java-management-extensions-jmx-agent ) section of the Virtual DataPort Administration Guide. In order to make this connection as described, I must first enable SSL/TLS in Denodo Platform Modules, the Denodo SSL/TLS Configurator script can be used to simplify this process, and I can find it at <DENODO_HOME>/bin/denodo_tls_configurator. Detailed information about the usage and parameters of this script can be found in the[ Denodo SSL/TLS Configurator Script](https://community.denodo.com/docs/html/browse/8.0/en/platform/installation/postinstallation_tasks/enable_ssl_connections_in_the_denodo_platform_servers/denodo_tls_configurator_script#denodo-ssl-tls-configurator-script) section of the Denodo Platform Installation Guide. Additionally, I would verify that I have executed the regenerateFiles script since making any configuration changes, and that the User trying to make the connection has Administrator privileges. The regenerateFiles script can be found at <DENODO_HOME>/bin. Hope this helps!
Denodo Team
14-05-2021 16:58:03 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here