You can translate the question and the replies:

About Denodo 7 and Denodo 8 Linux JDBC driver

Hi team, I have some python script which use linix JDBC driver to run some vql to Denodo 7, now our Denodo upgrade to Denodo 8, Can i understand the Denodo 7 JDBC driver cannot run vql like create/delete Denodo objects to Denodo 8? If I want to run vql to Denodo 8, I need to use the Denodo 8 Linux JDBC driver? Also I used "$DENODO_HOME/bin/import.sh" to run objects creating vql on linux server to create dv objects on Denodo 7, Can I understand the "$DENODO_HOME/bin/import.sh" compatible on Denodo 7 and Denodo 8? Or I can only use Denodo 7 import.sh to run vql to only Denodo 7, and Denodo 8 import.sh to run vql to only denodo 8? Please help confirm. Thanks.
user
07-07-2021 10:36:21 -0400

1 Answer

Hi, The JDBC driver of Denodo 7.0 returns an error on connecting to Denodo 8.0, or to earlier versions. So, please use the Denodo 8.0 JDBC driver to run vql on Denodo 8.0. Similarly, the import script has the Denodo Home set to its appropriate version of Denodo. Also, class paths for some of the jar files are added in Denodo 8.0. Therefore, I suggest that you use the import script for the respective versions. Hope this helps!
Denodo Team
07-07-2021 14:25:17 -0400
You must sign in to add an answer. If you do not have an account, you can register here