You can translate the question and the replies:

How to solve QUERY_TIMEOUT

How can I solve the QUERY_TIMEOUT after 900 seconds. My connection is: Driver class: oracle.jdbc.OracleDriver Database URI: jdbc:oracle:thin:@10.187.18.24:1521/DOKO As explained in Developer guide, I tried: jdbc:oracle:thin:@10.187.18.24:1521/DOKO?queryTimeout=900000 But that does not work ------------------------------------------- Never mind. I already found it: Tools - Admin Tool preferences
user
22-04-2015 09:26:39 -0400

8 Answers

Hi, As you said, you can define the query timeout from the VDP Admin Tool: "Tools -> Admin Tool Preferences -> Connection". You can also define this parameter using the context when running a query from the VQL Shell ("Tools -> VQL Shell"). Ex.: "SELECT * FROM my_view CONTEXT ('QUERYTIMEOUT'='900000'). For more information, see Section "Context Clause" from the "Advanced VQL Guide". Setting the query timeout at the URI is valid when connecting from external clients to VDP, as you can read in the "Developer Guide" (Section "Access through JDBC"). Cheers.
Denodo Team
23-04-2015 11:42:47 -0400
its not clear .what is the actual solution-do we need to make timout to 0? or increase it to some long integer?what time out means?
user
11-08-2018 04:20:59 -0400
Hello! In the [Tool Preferences](https://community.denodo.com/docs/html/browse/6.0/vdp/administration/installation_and_execution/launching_the_virtual_dataport_administration_tool/tool_preferences) section of the Virtual Administrator Guide, Query timeout is explained as follows: > Query timeout (milliseconds): Maximum time the Administration Tool will wait for a query to finish. If zero, it will wait indefinitely until the sentence ends. This setting can be defined in the Admin Tool by going to “Tools -> Admin Tool Preferences -> Connection” or you can also define this parameter using the context clause when running a query from the VQL Shell as explained above. You can set the value to a custom number of your choosing or set it to zero to get the maximum wait time for the query to finish. Hope this helps!
Denodo Team
13-08-2018 11:26:05 -0400
ok, so that sets the time out in the admin tool. but I seem to be getting consistent timeouts at 15 minutes for long queries from my application. my app has the jdbc driver, and it calls denodo with a vql query against a known long running teradata query. is there an equivalent denodo jdbc time out setting I need to set? I am getting someething like this on teh denodo server...Here is the error message – 196372865 [Access(19045)-15310-01.00-singularity_virtual.claim_v] ERROR 2020-06-10T07:09:33.293 com.denodo.vdb.engine.wrapper.raw.jdbc.adapter.SQLPlugin [] - Error validating connection com.teradata.jdbc.jdbc_4.util.JDBCException: [Teradata JDBC Driver] [TeraJDBC 14.10.00.26] [Error 804] [SQLState 08S01] Socket communication failure for Packet receive Wed Jun 10 07:09:33 EDT 2020 socket orig=CITERDEV.LMIG.COM local=0.0.0.0/0.0.0.0:41742 remote=CITERDEVcop1.LMIG.COM/10.18.172.79:1025 keepalive=unavailable nodelay=unavailable receive=unavailable send=unavailable linger=unavailable traffic=unavailable concurrent=3 contimeout=10000 conwait=1000 connecttime=16 connecttotaltime=16 connectattempts=1 connectfailures=0 reconnectattempts=0 recoverable=false redrive=false failurecache={} cid=24d3493e
user
12-06-2020 15:24:23 -0400
Hi, You can configure the default connection timeout in the connection string (in miliseconds) by configuring the “queryTimeout” parameter of the connection URL, for example: jdbc:vdb://acme:9999/admin?queryTimeout=200000 For more information, please refer to the [JDBC Driver Parameters](https://community.denodo.com/docs/html/browse/7.0/vdp/developer/access_through_jdbc/parameters_of_the_jdbc_connection_url/parameters_of_the_jdbc_connection_url) document. Hope this helps!
Denodo Team
17-06-2020 12:30:55 -0400
as I said, that query time out parameter is currently set to 3600000 ms which is an hour. I consistently time out at 15 minutes. we are taking a look at jdbc parameter settings. I doubt its our firewall as those are typically defaulted to an hour. we also looked at our AMI ( machine image) default settings. but doubt that is it .
user
18-06-2020 08:22:59 -0400
Hi, The queryTimeout parameter that I mentioned in the previous comment is different from the one that is set directly in the admin tool which you have already done. Please note that the “queryTimeout” parameter should be configured in the database URL of your JDBC data source, for example: jdbc:mysql://localhost:3306/acme_crm?queryTimeout=200000 Hope this helps!
Denodo Team
24-06-2020 16:43:13 -0400
We were experiencing timeout issues even after updating both the settings in the VDP, standard query timeout and the stored procedure timeout settings for our MicroStrategy to Denodo JDBC connection. We opend a ticket with Denodo Support and they recommended to place the query timeout setting in the connection initialization string setting for our JDBC connection. For our JDBC connection we added "InitializationString=SET QUERYTIMEOUT TO 0" Supports comment was "We have reviewed your DSN settings, since you are using PostgreSQL driver to connect to Denodo the queryTimeout has to specified in the InitializationString property. This is how it should look in your Denodo_DataMarketplace DSN settings: 1. InitializationString=SET QUERYTIMEOUT TO 0; Refresh the Denodo connection in MicroStrategy BI tool (If required)." This worked for us.
user
24-06-2020 16:51:48 -0400
You must sign in to add an answer. If you do not have an account, you can register here