You can translate the question and the replies:

Troubleshooting document on common Java/JDBC configuration issues (on Windows)?

Just did a fresh install of Denodo and tried to set up a JDBC datasource pointing to SQL Server 2012, and got the following errors: JTDS Sql Server 2012 driver: Unable to create data source: Unable to establish connection: I/O Error: SSO Failed: Native SSPI library not loaded. Check the java.library.path system property. Microsoft Sql Server 2012 driver: Unable to create data source: Unable to establish connection: com.microsoft.sqlserver.jdbc.SQLServerDriver Not sure if related, but from the Denodo Control Centre, if I push STOP on the Virtual Dataport Server, I get: Unexpected error: connection refused. (This is on Windows 7x64 Pro) This kind of looks like a situation of Java not being configured properly - the last time I had to mess around with java configuration was for splunk and it was a very frustrating experience of try this, google that, try this, and so on. Is there a troubleshooting / configuration guide specifically on this topic?
user
28-05-2015 14:20:25 -0400

4 Answers

Hi, Have you downloaded the driver and copied the jar to '%DENODO_HOME%/extensions/thirdparty/lib'? You can refer to this KB (https://community.denodo.com/kb/view/document/Security/Accessing%20MS%20SQL%20Server%20using%20Windows%20Authentication) to know more about the steps to configure a JDBC with MS SQL Server. Also, check out the answer to a similar question (https://community.denodo.com/answers/question/details?questionId=90670000000CcQyAAK ). I would also suggest you to run 'netstat -nb' in windows command prompt to make sure SQL Server is running and the port you provided in the connection string is correct. Hope this helps.
Denodo Team
29-05-2015 07:41:44 -0400
https://community.denodo.com/kb/view/document/Security/Accessing%20MS%20SQL%20Server%20using%20Windows%20Authentication #1. Using the jTDS JDBC driver The SourceForge site for jTDS driver is offline. #2. Using the Microsoft JDBC driver Following the steps outlined in the KB article yields: ...results in: Unable to create data source: Unable to establish connection: com.microsoft.sqlserver.jdbc.SQLServerDriver You know, assuming it is actually possible to connect to SQL Server from Denodo, it might perhaps be in your best interests to put a **comprehensive** set of required steps into **one single authoritative (and correct) document**, rather than having each of your potential customers following a labyrinth of multiple links in your support forums in a desperate effort to get all the various settings configured properly. Just an idea.
user
22-07-2015 14:22:37 -0400
Why don't you try a simple test with a named SQL Server account instead of Windows Auth and eliminate that variable with to start? We use SQL Server connections across the board for named and domain accounts and it works fine on both drivers and both authentication methods. It's not really a labyrinth - if you want to use NTLM/Windows Auth, you just need to copy a single file to a specified location and format your connection string slightly differently. If you want to use the native MSSQL driver, you just have to drop it in the classpath since it doesn't come out of the box. You asked for a guide specifically on this topic, and you got it. Your issue is specific to you trying to connect via a domain account.
user
23-07-2015 16:20:41 -0400
Hi, After you have downloaded the JDBC driver you have two options to use it: 1. Copy the jars in DENODO_HOME/extensions/thirdparty/lib and VDP will automatically load them when it starts. Note that you need to restart VDP after copying new jars to that folder if VDP has already started. 2. When creating a new JDBC data Source you can click on 'Browse' for the 'Driver class path (optional)' field and point to the jar in the filesystem. You don't have to restart VDP if you choose this method. Hope this helps.
Denodo Team
24-07-2015 03:58:29 -0400
You must sign in to add an answer. If you do not have an account, you can register here