You can translate the question and the replies:

Document on Resource Manager

Hi, Can you please share the link where i can find the documents on Resource manager so that i can lear more about it
user
04-11-2016 08:46:18 -0400

7 Answers

Hi, If you want to know more about the Resource Manager I recommend you to take a look at the "RESOURCE MANAGER" section of the "Virtual DataPort Administration Guide". https://community.denodo.com/docs/view/document/Virtual%20DataPort/Denodo%206.0/Virtual%20DataPort%20Administration%20Guide Hope this helps!
Denodo Team
07-11-2016 08:21:05 -0500
Hi, Thanks for the response, But still i cant find a way to restrict a query using high RAM. I want to create a plan which should kill a query using more than 80 percent of RAM. Is their any possibilities ????
user
17-11-2016 05:56:56 -0500
Hi, When I need to manage queries with a high memory usage I do it through the memory settings of the Denodo Platform. This feature allows you to handle the memory usage at three different levels: server, database and view level. If you are interested in the management of memory usage you can take a look at the "CONFIGURING THE MEMORY USAGE AND SWAPPING POLICY" section of the "Virtual DataPort Adminitration Guide". Hope this helps!
Denodo Team
22-11-2016 12:05:51 -0500
Hi, Thanks for the response, To test Resource manager i have created a plan to kill if query running for more than 1800000 millisecond , and then i created a rule with condition *username = 'user1*' . But its not working , i used query ``` select * from wait(2000000) ``` but it didnt killed the query. May i know where i am missing
user
23-11-2016 09:07:22 -0500
It worked for me. I created a plan to stop queries when have reached a maximum execution time (5000 ms), then I created a rule to assign the queries sent by the user "user_1" to the previous plan and after executing the query "select * from wait(7000)" with user_1 I got the following error: Finished with error: Error executing query. Total time 5.001 seconds. QUERY [PROJECTION] [QUERY_TIMEOUT] WAIT [STORED_PROCEDURE] [QUERY_TIMEOUT] WAIT [STORED PROCEDURE] [QUERY_TIMEOUT] I would recommend making sure that the Resource Manager is "on", the rule is assigning queries to the corresponding plan to stop them and you are querying with the correct user.
Denodo Team
28-11-2016 06:17:56 -0500
Hey Thanks, Yep, it worked for me too, order of the rules was the issue. But still the option to stop the query when CPU usage more than _ _ % is not working . .To keep it simple i created a Plan and a restriction With condition CPU usage is equal to or greater than 5 % and then assigned it to a rule with always condition...But it didnt stopped the query. Please verify it once
user
02-12-2016 06:43:32 -0500
Hi, Stopping the query when CPU usage is greater than a specified value worked for me. The VQL shell returned the following message: "Finished with error: Error: Query stopped". Maybe the query you are running does not reach the 5% of CPU usage you have specified. We would recommend changing the value with 0% of CPU usage and try to run the following query through VQL Shell: "select 1 from dual()". Hope this helps!
Denodo Team
12-12-2016 05:54:07 -0500
You must sign in to add an answer. If you do not have an account, you can register here