Restful Webservice - page not found

Hi When I browse to the default restful webservice ( http://[server]:9090/denodo-restfulws/[database]/views/[viewname] I get a page error: The page you requested was not found. The page may no longer exist, or you may have typed the URL incorrectly. Can you please advise why I sometimes get this error, and other times it works fine? I assume it's something that's not started? We're running on Windows. Thanks Cheers
User
14-03-2017 03:15:53 -0400

4 Answers

Hi, **Denodo Platform** includes an installation of **Apache Tomcat** that is used as internal web container. By default, every time when the Virtual DataPort server starts up, the Web service embedded container is started up too. I would check that the internal web container of the Denodo Platform is started and working. You can check it by using the** Virtual DataPort Administration tool** in the menu **"Tools" > "Web service container"** and also by executing the following VQL command: ***webcontainer status***. **I see that error page when the web container is still starting**. Hope this helps!
Denodo Team
14-03-2017 05:56:22 -0400
Hi. Thanks for the response. The webcontainer is started, but I still get the same error. Is there anything else I can check? You can see a screenshot here: https://drive.google.com/open?id=0B172Ezha5-qWZlFVOHpNMkdhOUk Thanks Cheers
User
23-03-2017 02:19:27 -0400
we are also facing the same issue. would you please share the your resolution TIA
user
15-05-2019 00:27:16 -0400
Hi, I am able to resolve the problem by restarting the web container. I would suggest to check the Apache Tomcat logs located at** <DENODO_HOME>\resources\apache-tomcat\logs\** to see if there are any errors logged related to the web container. Hope this helps!
Denodo Team
23-05-2019 08:15:02 -0400
You must sign in to add an answer. If you do not have an account, you can register here