You can translate the question and the replies:

Flatten field is greyed out in flatten wizard

I'm trying to flatten some json data coming in and no matter where I click in a results array through the flatten wizard the "flatten field...xyz" option is greyed out. What am I missing?
user
14-01-2016 13:27:03 -0500

1 Answer

Hi! Is the field a register or an array? You are correct that array fields may be flattened by creating a ‘flatten’ view and selecting the ‘flatten array <array_name>’ option by right clicking on the field in the model tab. However, if the field is a register, you may flatten the field in the output tab of any derived view type by right clicking on it and selecting ‘project subfields of <register_name>.’ Hope that helps!
Denodo Team
14-01-2016 22:05:10 -0500
You must sign in to add an answer. If you do not have an account, you can register here