You can translate the question and the replies:

Solution Manager Container reports Licence file not found

Hi, I get **Error**: "License file not found", even when the file is (I think) correctly placed with correct contents. **background** Downloaded latest solution manager container image (8.0-20220815) and uploaded this to local docker with kubernetes enabled followed the [relevant documentation dated 16.08.2022](https://community.denodo.com/kb/en/view/document/Deploying%20the%20Denodo%20Solution%20Manager%20in%20Kubernetes) to generate a configmap for the license which have been downloaded from denodo. used "kubectl create -f " on the yaml from documentation (hostname modified to test-denodo-sm, else no changes) **Verfications done** Verified the configmap by using "kubectl edit configmap solution-manager-license" (did no changes, but confirmed the right value was there) logged on to server and verified license file presence and contents => it is placed as /opt/denodo/conf/denodo.lic and contains the expected license key (no pre or post-fix). I've tried both with and without line-shift at the end of the license key. **Error details** Dump of start of log fetched using "kubectl logs": ``` denodo 09:44:08.08 INFO ==> Container scripts version 1.0.0+20220629 denodo 09:44:08.08 INFO ==> ** Starting Denodo setup ** denodo 09:44:08.09 INFO ==> Initializing Denodo ... denodo 09:44:08.13 INFO ==> Regenerating files ... denodo 09:44:08.87 INFO ==> Regenerated files denodo 09:44:09.73 INFO ==> ** Denodo setup finished! ** denodo 09:44:09.75 INFO ==> ** Starting License Manager ** [LM] 839 [main] INFO 2022-09-01T09:44:10.617 server.start [] - Starting Denodo License Manager Server 8.0 20220815 - Operating system: Linux (amd64) - OpenJDK Runtime Environment (build 11.0.8+10) - OpenJDK 64-Bit Server VM (build 11.0.8+10, mixed mode) [LM] 11517 [main] ERROR 2022-09-01T09:44:21.295 com.denodo.solutionmanager.service.LicenseService [] - License file not found [LM] 11517 [main] ERROR 2022-09-01T09:44:21.295 com.denodo.solutionmanager.service.LicenseService [] - License file not found com.denodo.solutionmanager.exceptions.ServiceException: License file not found at com.denodo.solutionmanager.service.LicenseService.addGlobalLicense(Unknown Source) ~[solution-manager-lib.jar:8.0.6] at com.denodo.solutionmanager.service.LicenseService.loadLocalLicenseAsGlobalLicense(Unknown Source) ~[solution-manager-lib.jar:8.0.6] at com.denodo.solutionmanager.service.LicenseService.checkGlobalLicenseIsLoaded(Unknown Source) ~[solution-manager-lib.jar:8.0.6] at com.denodo.solutionmanager.service.LicenseService$$FastClassBySpringCGLIB$$98dfa81b.invoke(<generated>) ~[solution-manager-lib.jar:8.0.6] at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:218) ~[spring-core-5.3.20.jar!/:5.3.20] at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.invokeJoinpoint(CglibAopProxy.java:793) ~[spring-aop-5.3.20.jar!/:5.3.20] at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:163) ~[spring-aop-5.3.20.jar!/:5.3.20] ```
user
01-09-2022 06:31:32 -0400

5 Answers

Hi, I would first check the “[Container quickstart guide](https://community.denodo.com/docs/html/document/8.0/en/Denodo%20Platform%20Container%208.0%20QuickStart%20Guide)” link from the Knowledge Base document you mentioned in your question as a prerequisite, as it serves to check that the Solution Manager container is working successfully in the Docker installation.” Please also pay attention carefully at “Licenses Managed by a Denodo Solution Manager” section in the “Denodo Platform Container 8.0 QuickStart Guide” as well for license verification. Hope this helps.
Denodo Team
02-09-2022 05:22:59 -0400
Hi Another thought that might be a possibility of this type of error is if the license file has a permission/ownership inappropriately then this can happen. Please also make sure to check that this has been verified as well with the command line below. ls -al /opt/denodo/conf/denodo.lic Hope this helps.
Denodo Team
04-09-2022 22:29:14 -0400
Hi, thank you for the initial answers. The default ownership of the volume seems to be "root" with read to Denodo application user. Looks like something which may cause issues for the container. But how to change it? Looking at kubernetes documentation I added "fsGroup: 999" to the .yaml specification, after this the file comes out as: -rw-r--r-- 1 root denodo 44 Sep 5 06:05 denodo.lic but still the file is only read only for the denodo user (and error is there) I tried changing it on the running container - but the file is "locked" and not available for the user to change. I do not see any comment on file ownership inside the documentation. How should I proceed? As a work-around I tried to cheat by noting the error on license happens around 10 seconds after pod startup. So I fully removed references to volume/configmap and instead manually created the required license file as a denodo user using re-directed echo command ca 5s after startup. Still the error is reported. (as a comment to the first answer: It is the Denodo Solution Manager that reports failure and fails to startup. The comment on “Licenses Managed by a Denodo Solution Manager” is valid only when the SM is working and the VDP should use this as a source for license.)
user
05-09-2022 02:58:46 -0400
Solution: license file contents was wrong. Not having direct access to the license source I got only the key, and not the full context of the file. Hence the file contained only the key and not anything else. For others to avoid the same: add a note that the file contain several lines of text where the second line contain the license key? I found a note on this here: https://community.denodo.com/kb/en/view/document/Is%20there%20a%20way%20to%20see%20what%20license%20is%20installed%3F?category=Operation which put me on the right track.
user
05-09-2022 05:59:40 -0400
Hi, Glad that the issue has been resolved and things are now back on track. Also thank you for sharing the URL to share your discovery. Hope you enjoy using Denodo solution..
Denodo Team
06-09-2022 04:39:34 -0400
You must sign in to add an answer. If you do not have an account, you can register here