You can translate the question and the replies:

ping command is not working

Hi I am trying to ping denodo scheduler and other services using the command you gave but I am unable to do it. ping -t 3000 -v //localhost:9999 getting error as"ping: ttl 3000 out of range" I ahve tried other ping command as it is mentioned in documentaion but getting same error. Please provide me ping command for all denodo services including license manager,vdp,scheduler,design studio and etc. Thanks
user
16-09-2022 10:06:08 -0400

3 Answers

Hello, I understand that you want to be able to ping all the Denodo services to check their availability. The error “ping: ttl 3000 out of range” indicates that the timeout parameter is encountering the issue. I would suggest that you try to execute the command without the “-t flag ” and check if that resolves the error. As that’s an optional parameter for the command. Also, you can replace the “localhost” with the actual IP address, this will eliminate the command’s preprocessing step of trying to resolve the value of “localhost” before executing the command. For example, you can run commands like the following to ping the VDP server: `ping -q "SELECT 1" -l admin -p <password> //192.168.200.192:9999/admin` or `ping -v //192.168.200.192:9999` I was able to ping the Scheduler server by first starting the scheduler server from Denodo Platform Control Center. Thereafter, I navigated to the folder containing the “ping” script for scheduler i.e <DENODO_HOME>\tools\scheduler. I executed this ping command in the command prompt for this path. You can refer to the [Use of Ping Script(Scheduler)](https://community.denodo.com/docs/html/browse/8.0/en/scheduler/administration/appendix/use_of_the_ping_script) document to get more information on the syntax of the ping script. My ping command and its response are as follows: ``` ping -v //192.168.200.192:8000 192.168.200.192:8000 - ping OK! Response time: 919 ms ``` Similarly you can ping the VDP server by starting the VDP server and navigating to the folder containing the “ping” script for vdp i.e <DENODO_HOME>\bin. You can refer to the [VDP Ping Script](https://community.denodo.com/docs/html/browse/8.0/en/vdp/administration/cluster_architectures_server_backup/how_to_check_if_a_virtual_dataport_server_is_alive/how_to_check_if_a_virtual_dataport_server_is_alive#how-to-check-if-a-virtual-dataport-server-is-alive) to get more information on the syntax of this ping script. The rest of the Denodo services are pinged by sending the HTTP GET request with the HTTP header “Authorization” for them and on success you receive status code 200. Please make sure the services are started before sending the HTTP ping request. You can refer to the [Health Monitoring](https://community.denodo.com/docs/html/browse/8.0/en/platform/installation/appendix/health_monitoring/health_monitoring) document to get the syntax of the HTTP GET request for different Denodo services and [Q/A](https://community.denodo.com/answers/question/details?questionId=9060g0000000BkcAAE&title=ping+script) to understand how to add HTTP “Authorization” header. Hope this helps!
Denodo Team
16-09-2022 20:36:19 -0400
sorry team, But it's not working.
user
16-09-2022 22:07:45 -0400
Hello, The ping command is used to check whether the intended Denodo service is alive or not. If it encounters an issue on execution, that’s because either the service is not reachable due to network issues or the service itself is not started. I would recommend to perform the following checks before executing the ping : 1. The service being pinged is started and is in “Running” state. 1. You are able to login to the service successfully. 1. The ping command is being executed from the correct directory in the Command Prompt. For example - * The VDP ping from : <DENODO_HOME>\bin * The Scheduler ping from : <DENODO_HOME>\tool\scheduler 1. Make sure the hostname i.e “localhost” or the IP address being used in the ping command is correct. If using hostname, go to **“Denodo Platform Control Center” > Configure > JVM Options > RMI Host **to confirm it for the specific denodo service. If using an IP address, go to **“Denodo Platform Control Center”** and you can see the IP value right before the **“Servers”**. If the issue still persists and you are a valid Support user, then please raise a Support case at the [Denodo Support Site](https://support.denodo.com/) so that our Support Team will help you further. Hope this helps!
Denodo Team
19-09-2022 20:08:58 -0400
You must sign in to add an answer. If you do not have an account, you can register here