You can translate the question and the replies:

full cache denodo express

i configured the cache in the server level by doning : 1-turn on the cache in the server configuration dialog under administration menu in the admin tool administration>server configuration>cache 2-in the connection i choosed the historical data source then i did : administration >database management i choose the database i'm working on it then selected cache then i choosed the data base denodo training and the data source historical orders 3- i did open the historical orders data source and i specified the historical scheme and i checked the Allow creating temporary tables, only for the data movement optimization i saveed everything i even restarted my computer my probleme ; i configured the cache for my base view ( delimited file ) in my data base then i did the " execute ,store data in cache ,retrieve rows " but when i execute it again i got 0 rows i checked the exucution trace and it is from the jdbcroute then i tried to exucute again but without the retrive all rows , i got only 150 rows so it cached only 150 what could be the probleme i have the admin data base with the vdpcachedatasource should i use it i foud it to hard
17-01-2023 17:05:18 -0500

1 Answer

Hi, I understand that you have enabled the cache at server level and in Database level you have selected the checkbox “**Specify an existing data source as cache**” and specified the following: > Database : denodo_training > Data source : ds_historical_orders After which you have enabled full cache mode for the view that has been created over the datasource ds_historical_orders. And your concern is that the view retrieves 0 rows when the cache mode is full. In general, when you are using the same database for both source and cache, the “Direct Data Load” will happen. This new feature has been added to the Virtual DataPort’s Cache Engine to enhance the cache load query's performance by delegating statements similar to “INSERT INTO ... SELECT …” directly to the cache database. The Direct Data Load feature helps to transfer the data directly to the cache table in the cache database “without going through Denodo” when the cache data source is the same as the data source of the view(source). Because of this, you are getting the message "Total rows received: 0 (shown 0). No results returned because the cache was loaded by direct data load." When you execute the view again with “**Retrieve all rows**” **selected**, and in the execution trace, you can see all the rows are retrieved from the cache. Besides, I would like to clarify that when the “Retrieve all rows” are **unchecked**, the number of rows being fetched from the cache database will be based on the "Display rows" parameter. By default, the “Display rows” are set to 150. For further details on this, you can take a look at **[Using the VQL Shell](** section of the Virtual DataPort Administration Guide. You could also refer to the **[Full Mode](** section of the Virtual DataPort Administration Guide for more details about the full cache. Hope this helps!
Denodo Team
18-01-2023 06:30:26 -0500
You must sign in to add an answer. If you do not have an account, you can register here