You can translate the question and the replies:

Ampersand in data source is replaced with &

Oracle source data shows that the value of a record is: **Ernst & Young** However when querying the data from denodo, the record gets translated to: **Ernst & Young** How do we automatically set the base view column so that special characters such as & will be transmitted or show up in denodo as is instead of & ?
user
29-06-2023 07:42:54 -0400
code

1 Answer

Hi, Unfortunately I can read *Ernst & Young* in both your option, probably the community forum is translating one of them. However I suggest you to try reading the same data with a different JDBC/ODBC client and check if they have the same behavior. Denodo usually does not automatically translalte html entities in their corresponding characters and neither the opposite. In case you're trying to read *'& amp;'* as *'&'* you can use the replace function in a new field of a selection view. ``` select REPLACE("your_field", '&', '&') from "database_name"."your_base_view"; ``` Hope this helps
Denodo Team
30-06-2023 07:41:22 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here