You can translate the question and the replies:

Denodo express 8 instllation under Mac os Ventura

Hi, I have installed denodo express 8 and when comes to install the update the instllation error at updateRemoteWebApps.sh I am running with sudo -E ./install.sh and the JAVA_HOME is set appropriately with JAVA version 11 as per below. Can you help to see what possible area causing the such error? Adrian JAVA version: java 18.0.2.1 2022-08-18 Java(TM) SE Runtime Environment (build 18.0.2.1+1-1) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2.1+1-1, mixed mode, sharing) Error log 46996 [main] ERROR 2023-09-20T20:22:00.608 com.denodo.patcher.commands.interpreter.Interpreter - Error executing "executeScript ${install.dir}/setup/vdp/updateRemoteWebApps.sh" java.lang.Exception: There were errors while executing the command : null at com.denodo.patcher.commands.ExecuteCommand.doExec(ExecuteCommand.java:60) ~[denodo-update.jar:?] at com.denodo.patcher.commands.AbstractCommand.exec(AbstractCommand.java:34) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:301) ~[denodo-update.jar:?] at com.denodo.patcher.commands.ExecuteCommandIf.runCommand(ExecuteCommandIf.java:68) ~[denodo-update.jar:?] at com.denodo.patcher.commands.ExecuteCommandIf.doExec(ExecuteCommandIf.java:46) ~[denodo-update.jar:?] at com.denodo.patcher.commands.AbstractCommand.exec(AbstractCommand.java:34) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:301) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:133) ~[denodo-update.jar:?] at com.denodo.patcher.Update.installPatches(Update.java:1465) ~[denodo-update.jar:?] at com.denodo.patcher.Update.<init>(Update.java:791) ~[denodo-update.jar:?] at com.denodo.patcher.Update.main(Update.java:1584) ~[denodo-update.jar:?] 247009 [main] ERROR 2023-09-20T20:22:00.621 com.denodo.patcher.commands.interpreter.Interpreter - Error executing "executeCommandIfInstalled vdp[vdpserver] "executeScript -os=linux ${install.dir}/setup/vdp/updateRemoteWebApps.sh"" java.lang.Exception: There were errors while executing the command : null at com.denodo.patcher.commands.ExecuteCommand.doExec(ExecuteCommand.java:60) ~[denodo-update.jar:?] at com.denodo.patcher.commands.AbstractCommand.exec(AbstractCommand.java:34) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:301) ~[denodo-update.jar:?] at com.denodo.patcher.commands.ExecuteCommandIf.runCommand(ExecuteCommandIf.java:68) ~[denodo-update.jar:?] at com.denodo.patcher.commands.ExecuteCommandIf.doExec(ExecuteCommandIf.java:46) ~[denodo-update.jar:?] at com.denodo.patcher.commands.AbstractCommand.exec(AbstractCommand.java:34) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:301) ~[denodo-update.jar:?] at com.denodo.patcher.commands.interpreter.Interpreter.execute(Interpreter.java:133) ~[denodo-update.jar:?] at com.denodo.patcher.Update.installPatches(Update.java:1465) ~[denodo-update.jar:?] at com.denodo.patcher.Update.<init>(Update.java:791) ~[denodo-update.jar:?] at com.denodo.patcher.Update.main(Update.java:1584) ~[denodo-update.jar:?]
user
20-09-2023 08:29:18 -0400
code

1 Answer

Hi, I would use './installer_cli.sh' install instead of 'install.sh'. Use the [command line installer guide](https://community.denodo.com/docs/html/browse/latest/en/platform/installation/using_the_command_line_installer/using_the_command_line_installer) to follow the installation instruction. Please check out the answer to this [question](https://community.denodo.com/answers/question/details?questionId=9060g0000004FMEAA2&title=Install+Denodo+on+mac). Hope this helps!
Denodo Team
21-09-2023 05:50:50 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here