To use the API of MySQL to perform bulk data loads, the system variable “local_infile” of MySQL has to be enabled.

  • For MySQL 8.x:

    1. Execute this command in MySQL with an administrator account to check if “local_infile” is enabled:

      SHOW GLOBAL VARIABLES LIKE 'local_infile';
    2. If the setting is disabled execute this in MySQL to enable it:

      SET GLOBAL local_infile = true;
  • MySQL 5.x: with the default configuration, “local_infile” is enabled so you do not have to change anything.

Add feedback