Software Requirements

Verify that the servers where you install the Denodo Platform meet these software requirements.

Supported Operating Systems

The Denodo Platform is supported on the following operating systems:

  • Windows: Windows Server 2019, Windows Server 2016, Windows Server 2012, Windows Server 2008, Windows 10.

  • Linux:

    • Amazon Linux

    • Ubuntu 12.04 LTS or later

    • CentOS 8.x, 7.x and 6.x,

    • Red Hat Enterprise Linux (RHEL) 8.x, 7.x and 6.x

    • Oracle Linux 8.x, 7.x and 6.x

    • SUSE Linux Enterprise 12.x

For an updated list of the supported operating systems, contact the Denodo Support Team.

Supported Browsers

The Diagnostic & Monitoring Tool and the web administration tools are tested with Chrome 62.x, Microsoft Edge 41.x and Mozilla Firefox 57.x.

The Data Catalog is tested with Chrome 62.x, Microsoft Edge 41.x and Mozilla Firefox 57.x.

Software Requirements for ITPilot

Some features of ITPilot have additional requirements:

  • Browser pool: Microsoft Internet Explorer 10.x or 11.x to use the component Browser Pool.

  • Adobe Acrobat Professional 9 or 10 to extract data from PDF files using the Adobe PDF engine.

  • Apache OpenOffice 4.0.x or 4.1.x to extract data from Microsoft Word files.

You only need to satisfy these requirements if you are going to use these components. If not, ignore them.