Review the Virtual DataPort Metadata

Most of the time, the VQL file you obtained in the previous step can be imported into the new version without any modification. However, if you got the following warning when you obtained the VQL file from Virtual DataPort 7.0, you probably need to modify the metadata.

MIGRATION TO 8.0 - WARNINGS SUMMARY

If you did not get any warning, skip this page and go to the next step of the upgrade process (Import Settings and Metadata in to the New Installation).

To modify the metadata, you can go back to Virtual DataPort 7.0, modify the necessary elements and export the VQL again, or modify the VQL file.

The warnings you may get are:

#1. Modify the following views because they use the operators contains, containsand, containsor or iscontained…

Denodo 8.0 no longer supports the operators contains, containsand, containsor and iscontained. The export script returns a list of the views that use these operators. Before you import the metadata file into Denodo 8.0, modify the definition of these views to remove these operators. You can either modify the definition of the views from the version 7.0 or manually modify the VQL file.

The section Contains, Containsand, Containsor and Iscontained Operators explains how to replace these operators with their equivalent operator that are part of the standard SQL.


#2. The QUERYPLAN parameter of the CONTEXT clause is not supported in Denodo 8.0.

The parameter QUERYPLAN of the CONTEXT clause of the SELECT statements has been removed in Denodo 8.0. In this metadata file, this parameter has been removed from the definition of the views listed here, so they can be imported into the new version.

We suggest you enable the Cost-Based Optimizer and gather the statistics of the views involved in the definition of these views. That way, you ensure the optimizer chooses an efficient plan when querying this view. Setting the execution plan of a query manually (i.e. with the parameter QUERYPLAN) is difficult and usually led to choosing a worse plan than what the cost optimizer would choose.


#3. Operators contains, containsand, containsor and iscontained are not supported in Denodo 8.0 and have been removed from the capacities of the affected base views’ search methods.

You do not need to do anything regarding this message.


#4. Aracne data sources are not supported in Denodo 8.0.

Aracne and Google Search data sources were deprecated in the version 7.0 and have been removed from version 8.0. Remove them and any element that depends on them.


#5. Google Search data sources are not supported in Denodo 8.0.

See the note above.